Directory Contents Search << >>


DaVinci 4: Deployment für Windows 9x/ME / unicows.dll

Die Betriebssysteme Windows 95, Windows 98 und Windows ME sind nicht Unicode fähig. DaVinci 4 setzt daher auf die Microsoft Layer für Unicode auf. Wenn Ihre Anwendung nur für Windows NT/2000/XP/Vista oder Wine ausgeliefert wird, brauchen Sie nichts zu beachten.

Zur Funktion von DaVinci 4 unter Windows 9x/ME ist jedoch zusätzlich die Datei unicows.dll notwendig. Diese kann von Microsoft heruntergeladen werden und eignet sich auch zur kostenlosen Verteilung (Redistributable), sofern die Lizenzbedingungen eingehalten werden.

Alternativ gibt es noch eine Open-Source DLL namens opencow.dll mit geringerem Funktionsumfang, mit der DaVinci 4 ebenfalls unter Windows 9x/ME betrieben werden kann. Für die mitgelieferten Beispielprogramme reicht diese jedoch nicht aus. Opencow kann LGPL lizensiert werden, was in manchen Fällen vorteilhaft ist.

DaVinci 4 basiert auf der Microsoft Runtime Library msvcrt.dll. Diese DLL wird mit allen Windows-Versionen außer Windows 95 mitgeliefert.

.Liste der weiterverteilbaren Ausführungsmodule

.Deployment der OCX-Komponente

-


Valid HTML 4.01!